ForgeGradle1.2 for Gradle5+

6,119
226
1,177
Нашел тут новую версию FG для 1.7.10, которая работает с новым Gradle
Пример билд-скрипта
 
6,119
226
1,177
Все тоже, что и в gradle 5+
 
6,119
226
1,177
От того ,что проект не обновляется не значит, что он не работает
 

tox1cozZ

aka Agravaine
Модератор
7,536
486
2,348
На всех 5-х версиях Gradle работает, на 6.0 уже нет, сыпет такие ошибки. Думаю стоит уточнить в названии.
1612524174128.png
 
29
20
На всех 5-х версиях Gradle работает, на 6.0 уже нет, сыпет такие ошибки. Думаю стоит уточнить в названии.
Gradle (Groovy):
repositories {
    maven {
        url = "http://files.minecraftforge.net/maven"
        metadataSources({
            artifact()
        })
    }
}
Вроде решает проблему. На всякий случай можно и в buildscript.repositories добавить.
Ошибка происходит потому что гредл не находит .pom артифакта и ничего не делает дальше. Код сверху говорит ему что этот репозиторий может не содержать метадату.
Из документации:
Java:
/**
 * Indicates that this repository may not contain metadata files,
 * but we can infer it from the presence of an artifact file.
 */
void artifact();
 
6,119
226
1,177
Попробовал это на галактикрафте 1.7.10. Версию gradle поставил 6.8.2, добавил в repositories решение от @yopoyka, в buildscript.repositories не добавлял. Все прекрасно собралось.
Агравэйн, какой проект ты пытаешься собрать?
~~~
Т.к. в логе упоминаются либы скалы, попробовал собрать свой проект, написанный на ней: тоже все сработало прекрасно
 
Последнее редактирование:

tox1cozZ

aka Agravaine
Модератор
7,536
486
2,348
Да я сначала в buildscript только и добавил. Сейчас всё нормально, спасибо.
 
Сверху