Ошибка при запуске ExampleMod.

Версия Minecraft
1.12.2
API
Forge
23
1
Я скачал Forge MDK по этой ссылке: https://files.minecraftforge.net/maven/net/minecraftforge/forge/index_1.12.2.html
Затем распаковал архив, открыл в папке с распакованными файлами консоль команд и прописал там "gradlew genEclipseRuns" и "gradlew eclipse". Затем импортирую проект в Eclipse через "Import projects -> Gradle -> Existing Gradle Project". В строке "<mapEntry key="{MC_VERSION}" value="{MC_VERSION}"/>" файла "runClient.launch" заменяю "{MC_VERSION}" на 1.12.2.
(Знак доллара перед {MC_VERSION} я тоже заменил)
Затем нажимаю "Run runClient". Должен запуститься ExampleMod, но я получаю ошибку:
1608468770120.png
Что я сделал не так?
 
Последнее редактирование:
23
1
gradlew setupDecompWorkspace забыл.
Прописываю "gradlew setupDecompWorkspace", консоль выдаёт BUILD FAILED:

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: The Gradle Daemon - Gradle User Manual.
Daemon will be stopped at the end of the build stopping after processing

New Dep: net.minecraftforge:forge:1.12.2-14.23.5.2854_mapped_snapshot_20171003-1.12

FAILURE: Build failed with an exception.

* What went wrong:
Task 'setupDecompWorkspace' not found in root project 'Test'.

* Try:
Run gradlew tasks to get a list of available tasks. Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at Gradle | Search for Help with Gradle

Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0.
Use '--warning-mode all' to show the individual deprecation warnings.
See Command-Line Interface - Gradle User Manual

BUILD FAILED in 13s
 
160
2
48
Тут вариантов не много, либо в твоем gradle.properties есть строка org.gradle.configureondemand=true, которую нужно убрать, либо у тебя нету forgegradle и самым простым решением для тебя будет скачать mdk и работать непосредственно с ним.
 
23
1
Тут вариантов не много, либо в твоем gradle.properties есть строка org.gradle.configureondemand=true, которую нужно убрать, либо у тебя нету forgegradle и самым простым решением для тебя будет скачать mdk и работать непосредственно с ним.
Строка org.gradle.configureondemand=true отсутствует в gradle.properties. MDK я скачивал по той же ссылке, что вы мне написали.
 
1,185
28
282
Тут вариантов не много
ну... тут один вариант. выкинуть фг3(1.12 жи)
New Dep: net.minecraftforge:forge:1.12.2-14.23.5.2854_mapped_snapshot_20171003-1.12
выкидываешь в помойку. идешь и качаешь версии форджи на 4-6 ниже.
Еще советую сразу маппинги на stable_39 поменять.
 
23
1
ну... тут один вариант. выкинуть фг3(1.12 жи)

выкидываешь в помойку. идешь и качаешь версии форджи на 4-6 ниже.
Если я использую версии выше 14.23.5.2847, то при вводе "gradlew setupDecompWorkspace" я получаю те же ошибки что и в новейшей, но если я использую версию 14.23.5.2847 или более низкие (не проверял все, их много), то получаю новые ошибки:

To honour the JVM settings for this build a new JVM will be forked. Please consider using the daemon: The Gradle Daemon - Gradle User Guide Version 2.14.
This mapping 'snapshot_20171003' was designed for MC 1.12! Use at your own peril.
#################################################
ForgeGradle 2.3-SNAPSHOT-6084129e
MinecraftForge/ForgeGradle
#################################################
Powered by MCP
http://modcoderpack.com
by: Searge, ProfMobius, R4wk, ZeuX
Fesh0r, IngisKahn, bspkrs, LexManos
#################################################
:deobfCompileDummyTask
:deobfProvidedDummyTask
:getVersionJson
:extractUserdev
:extractDependencyATs SKIPPED
:extractMcpData SKIPPED
:extractMcpMappings SKIPPED
:genSrgs SKIPPED
:downloadClient SKIPPED
:downloadServer SKIPPED
:splitServerJar SKIPPED
:mergeJars SKIPPED
:deobfMcSRG SKIPPED
:decompileMc SKIPPED
:fixMcSources SKIPPED
:applySourcePatches
:remapMcSources SKIPPED
:recompileMc FAILED

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':recompileMc'.
Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "C:\Program Files\Java\jre1.8.0_271"

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

BUILD FAILED

Total time: 34.211 secs
 
6,091
226
1,177
JAVA_HOME должен быть установлен на расположение jdk, а не jre
 
23
1
JAVA_HOME должен быть установлен на расположение jdk, а не jre
Исправил JAVA_HOME. Ввожу в консоль команд "gradlew setupDecompWorkspace", затем "gradlew genEclipseRuns", затем "gradlew eclipse". Затем импортирую проект в Eclipse. Затем нажимаю "Run runClient", получаю новые ошибки.


console:
[19:09:16] [main/INFO] [GradleStart]: Extra: []
Exception in thread "main" java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders[imath]AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders[/imath]AppClassLoader and java.net.URLClassLoader are in module java.base of loader 'bootstrap')
at net.minecraftforge.gradle.GradleForgeHacks.searchCoremods(GradleForgeHacks.java:85)
at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:86)
at GradleStart.main(GradleStart.java:25)1609082015765.png
 
1,185
28
282
Грабли обнови.
в gradle/wrapper/gradle-wrapper.properties ставишь

distributionUrl = https\://services.gradle.org/distributions/gradle-4.10.3-bin.zip
И мой тебе совет: если ты только начал на эклипсе кодить - пересаживайся на идею(комьюнити) с плагином майн-дева. Он позволяет сразу ставить среду и не трахать себе мозг с установкой...
Так-же совет: маппинги ставь stable_39 - build.gradle
 
709
9
106
пересаживайся на идею(комьюнити) с плагином майн-дева. Он позволяет сразу ставить среду и не трахать себе мозг с установкой...
Раньше и не надо было ничего особо делать, чтобы установить эклипс. А теперь нужно setupINtelljRuns и ещё gradlew genEclipseRuns прописывать. Раньше всё было просто: "gradlew setupDecompWorkspace" и "gradlew eclipse", и всё! Profit, готово! Щас полный идиотизм...
Idea - если что просто навороченная программа, а eclipse - стандартная среда разработки, там почти нет ничего лишнего. Несмотря на то, что он иногда не знает что надо импортировать какой-нибудь класс, хотя он есть и его нужно импортировать самому.
screenshot.150.jpg
 
1,185
28
282
кхм. учитывая, что это для идеи...

Да и не просто так же советуют пересаживаться...(можно вспомнить ведроид СДК,)
Лично я не жалею, что пересел с эклипса на идею(Экл: 17-18 года. Идея: 18-тек. момент). И по своему опыту - намного удобнее...
 
6,091
226
1,177
java.lang.ClassCastException: class jdk.internal.loader.ClassLoadersAppClassLoadercannotbecasttoclassjava.net.URLClassLoader(jdk.internal.loader.ClassLoadersAppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoadersAppClassLoadercannotbecasttoclassjava.net.URLClassLoader
Довольно распространенная проблема в последнее время o_O
 
519
15
120
Проясню ситуацию. Сборка Forge MDK 2847 последняя наиболее стабильная (по крайне мере в моддинге) но для корректной работы при использовании Eclipse нужна версия около 18.09 или 18.12. Выходов несколько:
  1. Поставить Eclipse более старой версии;
  2. Попробовать Idea;
  3. Забить на устаревшую 1.12 и идти в ногу со временем, 1.16+ ждут своих модмейкеров.
 
519
15
120
Общедоступных ресурсов на 1.16 недостаточно, к сожалению.
Ну некоторые крупные моды, такие как Thermal Series и Mekanism уже обновились до 1.16, значит информация по продвинутому моддингу есть. Как говорится, кто ищет, тот найдёт. Форум кузни, англоязычные форумы, информации полно, главное знать как её искать, если гугл не находит что-то, попробуй сменить подход к поиску.
 
Сверху