Проблема с репозиториями forge

Версия Minecraft
1.7.10
API
Forge
229
3
18
Доброго времени суток. Возникла беда с репозиториями мавена. Мне нужна среда под forge 1.7.10 с поддержкой scala ЯП. Но беда не в скала, а в том, что все репозитории forge дают ошибку. Что делать, где найти рабочий репозиторий?

Вот что я пробовал за сегодня в целях решения проблемы:

Код:
Первая попытка:
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "gt"
            url = "https://gregtech.overminddl1.com/"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
        maven {
            url = "https://jitpack.io"
        }
        flatDir {
            dirs 'lib'
        }
    }
    dependencies {
        classpath 'com.github.CDAGaming:ForgeGradle:1c670759c5'
        classpath 'com.github.GTNH2:ForgeGradle:FG_1.2-SNAPSHOT'
        classpath name: 'common-3.2.0-v20060603'
    }
}
Ошибка:
1637708372946.png
Код:
Вторая попытка:
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "forge"
            url = "https://files.minecraftforge.net/maven"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
        flatDir {
            dirs 'lib'
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
        classpath name: 'common-3.2.0-v20060603'
    }
}
Ошибка:
1637708598068.png
Код:
Gradle (Groovy):
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "jitpack"
            url = "https://jitpack.io/"
        }
        maven {
            name = "forge"
            url = "https://maven.minecraftforge.net/"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
        flatDir {
            dirs 'lib'
        }
    }
    dependencies {
        classpath "com.github.asbyth:ForgeGradle:6f53277"
        classpath name: 'common-3.2.0-v20060603'
    }
}
Ошибка:
1637708807136.png
 
229
3
18
К сожалению, это не работает. Взял сейчас код с github, на который ссылка в посте - получил ошибку:
1637709673865.png

PSS: Всё работает, просто на последней попытке я обновил gradle на 6.8.3 и забыл вернуть обратно на 4.0. После отката на 4.0 и перехода на репозиторий из поста - всё заработало
 
Последнее редактирование:
Сверху