уже просто за***ло... ForgeGradle 1.2 (1.7.10)

Версия Minecraft
1.7.10
API
Forge
1,271
24
205
уже просто за***ло... ForgeGradle 1.2 (1.7.10)

Суть в том что он походу умирает быстрее чем 1.6.4 с его md5 кривыми,
пройдусь с нулей
Скачал FG1.2
Поменял maven ссылки в build.gradle

Java:
buildscript {
    repositories {
        maven {
            name = "maven"
            url = "https://repo1.maven.org/maven2"
        }
        maven {
            name = "forge"
            url = "https://repo.spongepowered.org/repository/forge-proxy/"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT'
    }
}

Далее заменил версию градла на 2.6-all
distributionUrl=https\://services.gradle.org/distributions/gradle-2.6-all.zip

Поставил fernflower-fixed.jar и его md5 по совету зарака
Начинаю установку gradlew setupDecompWorkspace eclipse
И угадайте что? Правильно! Джек-пот, ГДЕ ФОРДЖ ТО Б!?!
1620000582000.png

(Gradle написал BUILD SUCCESSFUL, а куда делся FML? не представляю)
 
Решение
Java:
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "gt"
            url = "https://gregtech.overminddl1.com/"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
        maven {
            name = "jitpack.io"
            url = "https://jitpack.io"
        }
    }
    dependencies {
        classpath 'com.github.GTNH2:ForgeGradle:FG_1.2-SNAPSHOT'
    }
}

И грабли 4.4.1(ласт под 1.7.10 рабочие)
179
7
76

Ну да, тоже эти танцы с бубном уже совсем заканали, лишний раз страшно даже старые репо трогать, а ну как в fml в астрал уйдёт
 
  • Like
Реакции: jopi
26
1
5
Java:
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "gt"
            url = "https://gregtech.overminddl1.com/"
        }
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
        maven {
            name = "jitpack.io"
            url = "https://jitpack.io"
        }
    }
    dependencies {
        classpath 'com.github.GTNH2:ForgeGradle:FG_1.2-SNAPSHOT'
    }
}

И грабли 4.4.1(ласт под 1.7.10 рабочие)
 
1,271
24
205
@xstmass Опять он либу lwjgl не видит...

Java:
java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_231]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_231]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_231]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_231]
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:135) [launchwrapper-1.12.jar:?]
    at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]
    at net.minecraftforge.gradle.GradleStartCommon.launch(Unknown Source) [start/:?]
    at GradleStart.main(Unknown Source) [start/:?]
Caused by: java.lang.UnsatisfiedLinkError: org.lwjgl.DefaultSysImplementation.getPointerSize()I
    at org.lwjgl.DefaultSysImplementation.getPointerSize(Native Method) ~[lwjgl-2.9.1.jar:?]
    at org.lwjgl.Sys.<clinit>(Sys.java:113) ~[lwjgl-2.9.1.jar:?]
    at net.minecraft.client.Minecraft.getSystemTime(Minecraft.java:2818) ~[Minecraft.class:?]
    at net.minecraft.client.main.Main.main(Main.java:79) ~[Main.class:?]
    ... 8 more

Это уже классика, я не понимаю почему градл не может адекватно всунуть огл
 
1,271
24
205
Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй... Господи помилуй...

решение: не используйте eclipse 2018, используйте oxygen, там всё прекрасно работает... Похожая проблема была с 1.5.2 и 2018, походу она кривая...
 
618
17
147
Это уже классика, я не понимаю почему градл не может адекватно всунуть огл
Помню при входе в моддинг 1.5.2 этот ГЛ так же насиловал мозги, я тогда скачал ручками ГЛ нужный да запихивал к либам.
Похожая проблема была с 1.5.2 и 2018, походу она кривая...
Она не кривая, там просто изменили то ли механизм импорта проектов, то ли что-то в этом роде. С старыми версиями оптимально Eclipse 2018-9 и старее.
 
Сверху