Градл перестал билдить

Сообщения
218
Лучшие ответы
2
Реакции
5
В моем же случае ошибка не ушла :( На сайты заходит нормально, вроде не блокированы. Папку удалял, фаерволл отключен.
Что еще может быть?

Bash:
* What went wrong:

A problem occurred configuring root project 'Mod'.
Could not resolve all dependencies for configuration ':classpath'.
Could not resolve net.md-5:SpecialSource:1.7.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve net.md-5:SpecialSource:1.7.3.
Could not get resource 'https://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7.3/SpecialSource-1.7.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/net/md-5/SpecialSource/1.7.3/SpecialSource-1.7.3.pom'.
peer not authenticated
Could not resolve org.apache.httpcomponents:httpclient:4.3.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve org.apache.httpcomponents:httpclient:4.3.3.
Could not get resource 'https://repo1.maven.org/maven2/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.pom'.
peer not authenticated
Could not resolve org.apache.httpcomponents:httpmime:4.3.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve org.apache.httpcomponents:httpmime:4.3.3.
Could not get resource 'https://repo1.maven.org/maven2/org/apache/httpcomponents/httpmime/4.3.3/httpmime-4.3.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/apache/httpcomponents/httpmime/4.3.3/httpmime-4.3.3.pom'.
peer not authenticated
Could not resolve com.github.abrarsyed.jastyle:jAstyle:1.2.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve com.github.abrarsyed.jastyle:jAstyle:1.2.
Could not get resource 'https://repo1.maven.org/maven2/com/github/abrarsyed/jastyle/jAstyle/1.2/jAstyle-1.2.pom'.
Could not GET 'https://repo1.maven.org/maven2/com/github/abrarsyed/jastyle/jAstyle/1.2/jAstyle-1.2.pom'.
peer not authenticated
Could not resolve net.sf.trove4j:trove4j:2.1.0.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve net.sf.trove4j:trove4j:2.1.0.
Could not get resource 'https://repo1.maven.org/maven2/net/sf/trove4j/trove4j/2.1.0/trove4j-2.1.0.pom'.
Could not GET 'https://repo1.maven.org/maven2/net/sf/trove4j/trove4j/2.1.0/trove4j-2.1.0.pom'.
peer not authenticated
Could not resolve com.google.code.gson:gson:2.2.4.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:RetroGuard:3.6.6

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
Could not resolve com.google.code.gson:gson:2.2.4.
Could not get resource 'https://repo1.maven.org/maven2/com/google/code/gson/gson/2.2.4/gson-2.2.4.pom'.
Could not GET 'https://repo1.maven.org/maven2/com/google/code/gson/gson/2.2.4/gson-2.2.4.pom'.
peer not authenticated
Could not resolve com.google.guava:guava:18.0.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve com.google.guava:guava:18.0.
Could not get resource 'https://repo1.maven.org/maven2/com/google/guava/guava/18.0/guava-18.0.pom'.
Could not HEAD 'https://repo1.maven.org/maven2/com/google/guava/guava/18.0/guava-18.0.pom'.
peer not authenticated
Could not resolve org.ow2.asm:asm-debug-all:5.0.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.ow2.asm:asm-debug-all:5.0.3.
Could not get resource 'https://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'.
peer not authenticated
Could not resolve com.github.tony19:named-regexp:0.2.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve com.github.tony19:named-regexp:0.2.3.
Could not get resource 'https://repo1.maven.org/maven2/com/github/tony19/named-regexp/0.2.3/named-regexp-0.2.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/com/github/tony19/named-regexp/0.2.3/named-regexp-0.2.3.pom'.
peer not authenticated
Could not resolve com.cloudbees:diff4j:1.1.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT
Could not resolve com.cloudbees:diff4j:1.1.
Could not get resource 'https://repo1.maven.org/maven2/com/cloudbees/diff4j/1.1/diff4j-1.1.pom'.
Could not GET 'https://repo1.maven.org/maven2/com/cloudbees/diff4j/1.1/diff4j-1.1.pom'.
peer not authenticated
Could not resolve net.sf.jopt-simple:jopt-simple:4.6.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:RetroGuard:3.6.6

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
Could not get resource 'https://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'.
Could not GET 'https://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'.
peer not authenticated
Could not resolve org.eclipse.core:jobs:3.5.300-v20130429-1813.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.core:jobs:3.5.300-v20130429-1813.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/core/jobs/3.5.300-v20130429-1813/jobs-3.5.300-v20130429-1813.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/core/jobs/3.5.300-v20130429-1813/jobs-3.5.300-v20130429-1813.pom'.
peer not authenticated
Could not resolve org.eclipse:osgi:3.9.1-v20130814-1242.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse:osgi:3.9.1-v20130814-1242.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/osgi/3.9.1-v20130814-1242/osgi-3.9.1-v20130814-1242.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/osgi/3.9.1-v20130814-1242/osgi-3.9.1-v20130814-1242.pom'.
peer not authenticated
Could not resolve org.eclipse.core:contenttype:3.4.200-v20130326-1255.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.core:contenttype:3.4.200-v20130326-1255.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/core/contenttype/3.4.200-v20130326-1255/contenttype-3.4.200-v20130326-1255.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/core/contenttype/3.4.200-v20130326-1255/contenttype-3.4.200-v20130326-1255.pom'.
peer not authenticated
Could not resolve org.eclipse.core:resources:3.2.1-R32x_v20060914.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.core:resources:3.2.1-R32x_v20060914.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/core/resources/3.2.1-R32x_v20060914/resources-3.2.1-R32x_v20060914.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/core/resources/3.2.1-R32x_v20060914/resources-3.2.1-R32x_v20060914.pom'.
peer not authenticated
Could not resolve org.eclipse.equinox:common:3.6.200-v20130402-1505.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.equinox:common:3.6.200-v20130402-1505.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/equinox/common/3.6.200-v20130402-1505/common-3.6.200-v20130402-1505.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/equinox/common/3.6.200-v20130402-1505/common-3.6.200-v20130402-1505.pom'.
peer not authenticated
Could not resolve org.eclipse.text:org.eclipse.text:3.5.101.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.text:org.eclipse.text:3.5.101.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/text/org.eclipse.text/3.5.101/org.eclipse.text-3.5.101.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/text/org.eclipse.text/3.5.101/org.eclipse.text-3.5.101.pom'.
peer not authenticated
Could not resolve org.eclipse.jgit:org.eclipse.jgit:3.2.0.201312181205-r.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.jgit:org.eclipse.jgit:3.2.0.201312181205-r.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/jgit/org.eclipse.jgit/3.2.0.201312181205-r/org.eclipse.jgit-3.2.0.201312181205-r.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/jgit/org.eclipse.jgit/3.2.0.201312181205-r/org.eclipse.jgit-3.2.0.201312181205-r.pom'.
peer not authenticated
Could not resolve org.eclipse.equinox:preferences:3.5.100-v20130422-1538.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.equinox:preferences:3.5.100-v20130422-1538.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/equinox/preferences/3.5.100-v20130422-1538/preferences-3.5.100-v20130422-1538.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/equinox/preferences/3.5.100-v20130422-1538/preferences-3.5.100-v20130422-1538.pom'.
peer not authenticated
Could not resolve net.sf.jopt-simple:jopt-simple:4.6.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve net.sf.jopt-simple:jopt-simple:4.6.
Could not get resource 'https://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'.
Could not GET 'https://repo1.maven.org/maven2/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.pom'.
peer not authenticated
Could not resolve org.eclipse.core:runtime:3.9.0-v20130326-1255.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > net.minecraftforge.srg2source:Srg2Source:3.2-SNAPSHOT
Could not resolve org.eclipse.core:runtime:3.9.0-v20130326-1255.
Could not get resource 'https://repo1.maven.org/maven2/org/eclipse/core/runtime/3.9.0-v20130326-1255/runtime-3.9.0-v20130326-1255.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/eclipse/core/runtime/3.9.0-v20130326-1255/runtime-3.9.0-v20130326-1255.pom'.
peer not authenticated
Could not resolve org.ow2.asm:asm-debug-all:5.0.3.

     Required by:

         :Mod:unspecified > net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT > de.oceanlabs.mcp:mcinjector:3.2-SNAPSHOT
Could not resolve org.ow2.asm:asm-debug-all:5.0.3.
Could not get resource 'https://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'.
Could not GET 'https://repo1.maven.org/maven2/org/ow2/asm/asm-debug-all/5.0.3/asm-debug-all-5.0.3.pom'.
peer not authenticated



* Try:

Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

UPD: Через Idea setupDecompWorkspace прошел успешно, через консоль не хотел.
 
Последнее редактирование:
Сообщения
936
Лучшие ответы
18
Реакции
75
1579428545124.png
Такая проблема, в чем рофл? До 2.6 обновил
UPD
решил, чота в буилдградле изменил и всеполучилось
 
Последнее редактирование:
Сообщения
207
Лучшие ответы
1
Реакции
16
устанавливайте отдельно 2.6 gradle, добавляйте путь к системной переменной path
проверяйте в консоли что версия именно 2.6 "gradle -version"
дальше просто используете не "gradlew.bat а gradle", можно обновлять и в каждой папке с модами, но это геморойней
в чем прикол - репозиторий forge перешел с HTTP на HTTPS а старые версии грабли плохо работают с сертификатами, если обновить граблю на новые высокие версии >2.6 то тогда отлетает ForgeGradle, который не совместим с ними
 
Сообщения
2
Лучшие ответы
0
Реакции
0
У меня в не зависимости от gradle выбивает вот такую ошибку


Пробовал версии MDK 1.12, 1.14, и 1.15, ошибка везде одна, менял версии JDK не помогло.
 
Сообщения
817
Лучшие ответы
21
Реакции
44
Звони провайдеру и узнай заблочены ли у тебя указанные в логах сайты. Я с таким столкнулся однажды. Как вариант - раздай сеть с мобилы и разверни проеет еще раз.
 
Сообщения
41
Лучшие ответы
0
Реакции
2
Дети малые, впн подрубите и все норм будет, пилите провайдера
 
Сообщения
8
Лучшие ответы
0
Реакции
0
@BestFoxy, в том то и дело, что его там менять негде)

@Cr1mmy , ты чёртов Господь Бог! Я бы тебя на руках носил! Спасибо огромное за помощь!
Команда не сработала, но ручная смена версии в конф-ге всё исправила. Правда у меня тут другая ошибка вылезла, но это явно что-то из-за моих неудачных поисков решений, хотя бы ту победил, спасибо!)

Посмотреть вложение 7351
на какую версию обновить
 
Сообщения
817
Лучшие ответы
21
Реакции
44
2.6
 
Сообщения
5
Лучшие ответы
0
Реакции
0
нужно обновить грабли на версию 2.6 и выше
2 способа:
1. прописать команду в терминале
gradlew wrapper --gradle-version 2.6
2. открыть gradle-wrapper.properties
в строке distributionUrl должно быть написано
Слушай, а вот во втором способе, что нужно там сделать?
 

tox1cozZ

aka Agravaine
Модератор
Сообщения
6,168
Лучшие ответы
348
Реакции
1,578
Изменить версию в указанной строке
 
Сообщения
2
Лучшие ответы
0
Реакции
0
2 месяца назад градл решил отправлять данные только по https - что бы какеры по дороге не подменили. А скрипт для 1.7.10 об этом не знает, его 5 лет назад писали. Можно попробовать ему локальный мавеновский репозиторий подсунуть
 
Последнее редактирование:
Сообщения
1
Лучшие ответы
0
Реакции
0
@axiom как?
upd : помогло изменение distributionUrl
 
Последнее редактирование:
Сообщения
55
Лучшие ответы
0
Реакции
2
в если у меня и там https?
JSON:
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
distributionUrl=https\://services.gradle.org/distributions/gradle-4.8.1-bin.zip
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
 
Сверху