PacketAPI

PacketAPI 1.3.0

Нет прав для скачивания
1,175
27
281
А что у тебя за ситуация ? баккит + форж ?
чистое ведро + клиент чистый фордж(адаптер 1.8)
для обывателя, этот способ проверки работать будет.
Ну.... Если я правильно из кода понял - только для серверов с форджой...

Плагин ругался мол версия сервера не подходит(1.8.8 к 1.8.8 верю,верю.) Полез выяснять - нашел такую фигню. После дополнительного чек-класса работает
 
214
11
56
Понятно. Так или иначе, это проблема. Я ее пока костылем с пропертей замазал. С последним коммитом можно принудительно установить версию игры так: -Dru.xlv.packetapi.gameVersion=1.8.3. Ну и, соответственно, твой адаптер должен быть по пути: ru.xlv.packetapi.capability.CapabilityAdapter1_8_3
 
1,175
27
281
принудительно установить версию игры так
не схавает) потому-что у тебя в initCapabilityAdapter идет та самая проверка, где я закостылил выше
(зы. v1.8.r3 - версия ведра у 1.8.х. я использую 1.8.8сервер, 1.8.9клиент)

Как вариант - можно добавить доп проверку на ru.xlv.packetapi.gameVersion в адаптеры... ну или где-нибудь еще :)
 
Сверху