Разобраться с forge

6,545
267
1,312
Так че, в итоге форжтим починили свой мавен? У мя старый проекты без правок билдскрипта запахали, зависимости заного скачались
 
6,545
267
1,312
у мя щас со всем старым заработало
 
1.7.10
Gradle (Groovy):
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "gt"
            url = "https://gregtech.overminddl1.com/"         
        }
        maven {
            url = "https://repo.spongepowered.org/repository/forge-proxy"
        }     
    }
    dependencies {
        classpath 'net.minecraftforge.gradle:ForgeGradle:1.2-SNAPSHOT' 
        //classpath "com.github.GTNH2:ForgeGradle:FG_1.2-SNAPSHOT"     
    }
}
apply plugin: 'forge'
Грабли 2.14
Пробуйте.
Спасибо. Желаю всего доброго
 
6,545
267
1,312
Нашел вот такую портянку: [ForgeGradle] Updating the old toolchains; a why, how, and where.
Это типо заметки о том, что делают в FG4.
И еще там есть приглашение в дис MinecraftForge, где появился канал #retrogradle, где люди обсуждают "как сделать старые версии счастливыми"
Если кто-то хочет пойти и помочь - вы знаете, куда
 
913
25
160
Еще одно рабочее решение для 1.7.10 (единственное для меня, кстати):
Gradle (Groovy):
buildscript {
    repositories {
        mavenCentral()
        maven {
            name = "sonatype"
            url = "https://oss.sonatype.org/content/repositories/snapshots/"
        }
    }
    dependencies {
        classpath ('com.anatawa12.forge:ForgeGradle:1.2-1.0.+') {
            changing = true
        }
    }
}
А грабли использовал 5.6.4.

И закрепите уже тему, чтобы найти было просто и потанцевально не плодились вопросы о том как фордж починить.
 

sk9zist :l

Зануда
907
15
138
913
25
160
Стоит добавить, что у себя я забыл прописать репозиторий forge (maven.minecraftforge.net), без которого патченый fg не будет работать.
 
913
25
160
Ну, я пока не добавил, в меня не работало. Правда, у меня ваще граблемайн странно работает.
 
Сверху